Erroring Install Driver ATI Catalyst in Slackware64 14 Current

— I am tried write in english, so any suggestion are welcome.

I ‘m get trouble when i want install ati driver. My hardware ATI Radeon HD 5770.
My steps.

1. Install slackware64
2. Upgarde to current
3. Download latest ati driver.
4. Install driver

First, i get error. Version.h not found. I get clue from
https://groups.google.com/forum/?fromgroups=#!topic/id-slackware/hDuotShbp0k

Just make symlink, here code :
# ln -s /lib/modules/3.7.1/build/include/generated/uapi/linux/version.h /lib/modules/3.7.1/build/include/linux/version.h

Second,  when i try insall driver ati again, i get another error.

Patch ATI Driver

Then i push this promblem to id-slackware in google group.

The answer :

1. Download this path (fglrx-3.7.patch), then copy file to/lib/modules/fglrx/build_mod/

2. Change directory
# cd /lib/modules/fglrx/build_mod/

3. Do Patching the fglrx source:
# patch -p0 < fglrx-3.7.patch

4. Do compile the fglrx modules:
# ./make.sh
# cd ..
# ./make_install.sh

5. Reboot.

Thanks all

Source :
[0] https://groups.google.com/forum/?fromgroups=#!topic/id-slackware/njis8rUfLWo
[1] http://henryhermawan.blogspot.com/2012/12/amd-catalyst-patch-for-kernel-37x.html

Regard
Tuan Pembual